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Preface

This preface introduces the Mali GPU Shader Development Studio User Guide. It contains the 
following sections:
• About this book on page v
• Feedback on page vii.
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Preface 
About this book
This book is for the Mali GPU Shader Development Studio User Guide. This book is part of a 
suite belonging to the Mali Developer Tools.

Intended audience

This book is written for first-time users of the Mali Shader Development Studio software. It 
assumes that the users are familiar with basic graphics processing concepts and the Eclipse 
software development environment.

Using this book

This book is organized into the following chapters:

Chapter 1 Introduction 
Read this for an introduction to the Shader Development Studio software. 

Chapter 2 Installing the software 
Read this for a description of how to install the Shader Development Studio 
software. The software is provided as a plug-in that can be installed into the 
Eclipse software development environment.

Chapter 3 The Shader Development Studio 
Read this for information on how to get started using the Shader Development 
Studio. This includes, setting up a new shader, importing an existing shader and 
using some of the features of the software.

Chapter 4 Configuring the Shader Development Studio 
Read this for a summary of all the functionality that is provided by the Shader 
Development Studio software.

Appendix A Shader Server 
Read this for information to use a remote renderer for the Shader Development 
Studio.

Glossary Read this for definitions of terms used in this book.

Typographical conventions

The typographical conventions are:

italic Highlights important notes, introduces special terminology, denotes 
internal cross-references, and citations.

bold Highlights interface elements, such as menu names. Denotes signal 
names. Also used for terms in descriptive lists, where appropriate.

monospace Denotes text that you can enter at the keyboard, such as commands, file 
and program names, and source code.

monospace Denotes a permitted abbreviation for a command or option. You can enter 
the underlined text instead of the full command or option name.

monospace italic Denotes arguments to monospace text where the argument is to be 
replaced by a specific value.

monospace bold Denotes language keywords when used outside example code.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. v
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Preface 
 < and > Enclose replaceable terms for assembler syntax where they appear in code 
or code fragments. For example:
MRC p15, 0 <Rd>, <CRn>, <CRm>, <Opcode_2>

Additional reading

This section lists publications by ARM and by third parties.

See Infocenter, http://infocenter.arm.com, for access to ARM documentation.

ARM publications

This guide contains information that is specific to the Mali Developer Tools. See the following 
documents for other relevant information:
• Mali GPU Developer Tools Technical Overview (ARM DUI 501)
• Mali GPU Performance Analysis Tool User Guide (ARM DUI 0502)
• Mali GPU Texture Compression Tool User Guide (ARM DUI 0503)
• Mali GPU User Interface Engine User Guide (ARM DUI 0505)
• Mali GPU Binary Asset Exporter User Guide (ARM DUI 0507)
• Mali GPU Shader Library User Guide (ARM DUI 0510)
• OpenGL ES 2.0 Emulator User Guide (ARM DUI 0511)
• Mali GPU Offline Shader Complier User Guide (ARM DUI 0513).

Other publications

This section lists relevant documents published by third parties:

• OpenGL ES 1.1 Specification at http://www.khronos.org.

• OpenGL ES 2.0 Specification at http://www.khronos.org.

• OpenGL ES Shading Language Specification at http://www.khronos.org.

• OpenVG 1.1 Specification at http://www.khronos.org.

• OpenGL Programming Guide: The Official Guide to Learning OpenGL, Version 2 (5th 
Edition, 2005), Addison-Wesley Professional. ISBN 0-321-33573-2.

• OpenGL Shading Language (2nd Edition, 2006), Addison-Wesley Professional. ISBN 
0-321-33489-2.
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Preface 
Feedback
ARM welcomes feedback on this product and its documentation.

Feedback on this product

If you have any comments or suggestions about this product, contact malidevelopers@arm.com 
and give:

• The product name.

• The product revision or version.

• An explanation with as much information as you can provide. Include symptoms and 
diagnostic procedures if appropriate.

Feedback on content

If you have comments on content then send an e-mail to errata@arm.com. Give:
• the title
• the number, DUI0504C
• the page numbers to which your comments apply
• a concise explanation of your comments.

ARM also welcomes general suggestions for additions and improvements.
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Chapter 1 
Introduction

This chapter provides information about the Mali GPU Shader Development Studio Tool, and 
describes how to install and start using the tool in your particular workflow. It contains the 
following section:
• About the Mali GPU Shader Development Studio on page 1-2.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 1-1
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Introduction 
1.1 About the Mali GPU Shader Development Studio
The Mali GPU Shader Development Studio is an Eclipse plug-in that extends the functionality 
of the Eclipse platform to enable editing of OpenGL ES 2.0 shaders. It can be used to develop 
shaders from scratch, or to work on existing shaders. 

You can preview shaders as they are being developed by rendering them on remote OpenGL ES 
2.0 hardware or on remote or local emulations.

The OpenGL ES Shading Language (ESSL) is used to develop shaders. For more information, 
see the OpenGL ES Shading Language Specification.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 1-2
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Chapter 2 
Installing the software

This chapter describes how to install the Shader Development Studio. It contains the following 
sections:
• Installation requirements on page 2-2
• Install and configure Shader Development Studio on page 2-4
• Configure the Shader Development Studio on page 2-8
• Uninstalling the Shader Development Studio Plug-in on page 2-13.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-1
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Installing the software 
2.1 Installation requirements
This section lists the installation requirements for the Shader Developer Studio software. The 
sections included are:
• JRE
• Eclipse
• Mali Developer Tools
• Installation overview.

Note
 The Shader Developer Studio has been tested successfully on a 32-bit computer.

2.1.1 JRE

You must download and install the Java Runtime Environment (JRE) for either Windows XP or 
Linux from http://www.java.com/. The latest update of JRE6 is recommended.

2.1.2 Eclipse

The Shader Developer Studio software is an Eclipse plug-in. 

Eclipse

Download and install Eclipse from http://www.eclipse.org/. Eclipse version 3.5.2 (or later) is 
required. 

2.1.3 Mali Developer Tools

The Shader Development Studio software uses the Offline Shader Compiler, on Windows this 
is malisc.exe, to check the syntax of shader source files.

The Offline Shader Compiler is a separate standalone tool. If the Offline Shader Compiler is not 
installed, the Shader Development Studio cannot perform syntax checking of the shader sources 
or gather performance statistics. You can download the Offline Complier from 
www.malideveloper.com.

The Mali GPU Shader Library is a separate collection of shader code samples. You can 
download the Offline Complier from www.malideveloper.com.

The OpenGL ES 2.0 Emulator is required for local rendering on a workstation. See the OpenGL 
ES 2.0 Emulator User Guide for installation instructions.

2.1.4 Installation overview

The Shader Development Studio plug-in is delivered as an Eclipse local update site package. To 
install the plug-in you can use the Eclipse update site mechanism. This is the recommended 
method for installing Eclipse plug-ins because it enables Eclipse to automatically manage the 
installation and un-installation of the plug-in, in addition to managing plug-in dependencies.

The installation procedure comprises of four steps:

1. Download the Shader Development Studio. One version covers both Windows and Linux.

2. Configure the Eclipse update manager with the location of the Shader Development 
Studio update site directory.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-2
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Installing the software 
Note
 The operating system used for this description was Windows, however with the exception 

to directory names, it is identical to using Linux. This is also applicable to steps 3 and 4.

3. Install the Shader Development Studio with Eclipse.

Note
 Depending on your version of Eclipse:

• Select Help → Software updates ... from the Eclipse menu bar.
• Select Help → Install New Software ... from the Eclipse menu bar.

4. Configure the Shader Development Studio.

These steps are described in the following sections.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-3
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Installing the software 
2.2 Install and configure Shader Development Studio
To configure the Eclipse Update Manager with the location of the update site directory for the 
Shader Development Studio plug-in:

1. Download the package:
a. Go to the Mali Developer Download Center web site at: 

http://www.malideveloper.com

b. Download the following package:
Mali_GPU_Shader_Development_Studio_m.n.o.p.zip

where:
m identifies the major version
n identifies the minor version.
o.p identifies the part and build version.

2. Start Eclipse.

3. Select Help → Install New Software ... from the Eclipse menu bar.
The Install Available Software dialog box is displayed. See Figure 2-1:

Figure 2-1 Available Software dialog

4. Click the Add button next to the Work with combo box.
The Add Repository dialog is displayed.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-4
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Installing the software 
5. Click Archive... to display the Browse For Folder dialog. 
Browse to the location of the Shader Development Studio update site zip file.

6. Click OK.
The Add Repository dialog box is updated with the location of the Shader Development 
Studio update site directory in the Location edit field.

7. Click OK.
The Install Available Software dialog box is updated with the location of the Shader 
Development Studio update site. See Figure 2-2:

Figure 2-2 Select Mali Developer Tools in the Install dialog

8. Check the box next to Mali Developer Tools.

9. Click Next in the Available Software dialog box.
The Install dialog box displays the item about to be installed. 

10. Click Finish in the Install Details dialog box.
A progress dialog box is displayed listing the components being installed
The Software Updates dialog box is displayed requesting you to restart Eclipse to 
complete the installation.

11. Click Yes to restart Eclipse.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-5
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Installing the software 
If the installation is successful, the Shader Development Studio is loaded automatically 
when Eclipse restarts.

12. To confirm that the installation was successful, select Window → Open Perspective → 
Other ....
The Open Perspective dialog box is displayed. See Figure 2-3:
Check that Shader Development Studio is listed in the dialog box. If it is not listed, the 
Shader Development Studio is not installed correctly.

Figure 2-3 Open Perspective dialog box

13. Click Shader Development Studio in the Open Perspective dialog box.

14. Click OK.
The Shader Development Studio perspective is loaded into Eclipse. See Figure 2-4 on 
page 2-7:
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-6
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Installing the software 
Figure 2-4 Shader Development Studio perspective loaded
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Installing the software 
2.3 Configure the Shader Development Studio
The Shader Development Studio has many configuration options that are available from the 
Eclipse Preferences dialog box. See Chapter 4 Configuring the Shader Development Studio for 
more information.

To view the Preferences dialog box:

1. Select Window → Preferences. 
The Preferences dialog box is displayed. The dialog box contains an entry for configuring 
the Shader Development Studio. See Figure 2-5:

Figure 2-5 Eclipse Preferences dialog box

2. To configure the Shader Development Studio so that you can begin using it:
• set the location of the Offline Shader Compiler
• select a renderer to be used by the Shader Development Studio.
These configuration options are provided from the Preferences dialog box. See the 
following sections for more information.

2.3.1 Set the location of the Offline Shader Compiler

The Offline Shader Compiler enables the Shader Development Studio to check the syntax of 
shaders before they are sent for rendering. This works by compiling each shader in the 
background and gathering data on any warnings or errors that are generated.

Note
 If you do not have the Offline Shader Compiler installed on your computer, there is no offline 
compiler to configure, so you can skip this section. Be aware that because you do not have an 
Offline Shader Compiler installed, no syntax checking of the shaders is performed and no 
gathering of performance statistics is performed.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-8
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Installing the software 
The Offline Shader Compiler is called malisc.exe and installed as part of the Mali Developer 
Tools. Set a path to where it is installed:

C:\Program Files\ARM\Mali Developer Tools\Mali GPU Offline Shader Compiler vm.n\bin 

To set the correct configuration, click on Shader Development Studio → Compiler in the 
Preferences dialog box. See Figure 2-6:

Figure 2-6 Eclipse Preferences dialog box with Compiler pane

To provide the location of the offline compiler:

1. Select the Compiler preference pane from the Preferences dialog box.

2. Ensure the Offline Shader Compiler is enabled by checking the Use Offline Compiler 
box.

3. Click Browse… and browse to the new location of malisc.exe. 

4. Click OK to set the new location.

2.3.2 Select a renderer

A renderer is used to perform the actual rendering of a shader effect. Any device that is capable 
of rendering OpenGL ES 2.0 shaders can be used for this purpose. This is a powerful concept 
that enables you to render your shader effects on local or remote OpenGL ES 2.0 emulations, or 
even on actual OpenGL ES 2.0 hardware, without performing any additional configuration.

The process depends on our operating system:
• Select a renderer for Windows
• Select a renderer for Linux on page 2-10.

Select a renderer for Windows

To select or add a renderer to be used by the Windows version of Shader Development Studio:

1. From the Preferences dialog box, select Shader Development Studio → Renderers to 
display the Renderers preference pane.
Use the Renderers preference pane to manage connections to the renderers. 
The Shader Development Studio is shipped with a local renderer, that is launched 
automatically at start-up by the Shader Development Studio. The local renderer appears 
in the list of renderers as Built-In Server. See Figure 2-7 on page 2-10:
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-9
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Installing the software 
Figure 2-7 Default Renderers dialog box

Note
 The local renderer requires that the OpenGL ES 2.0 Emulator version 1.3 is installed on 

your system.

2. Select the Built-In Server renderer.

3. If the device is not on the local network, you can add it manually by clicking Add 
Renderer. See Renderers on page 4-3 for more information on how to add a new renderer.

4. Click OK to save the preferences that have been set and to close the Preferences dialog 
box.

5. The Shader Development Studio software is now configured. 

Select a renderer for Linux

To select or add a renderer to be used by the Linux version of Shader Development Studio:

1. From the Preferences dialog box, select Shader Development Studio → Renderers to 
display the Renderers preference pane.

2. Click Add Renderer. The Add Renderer dialog is displayed. See Figure 2-8 on 
page 2-11:
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-10
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Installing the software 
Figure 2-8 The Add Renderer dialog

3. You can use either the renderer in the Emulator software or a renderer in a hardware 
device that contains a Mali GPU.
To use the Emulator renderer:
a. Copy the Emulator binary to the local library directory:

sudo cp <install_location>/ARM/Mali_Developer_Tools/OpenGL_ES_2_0_Emulator_m.n.o/bin/*.so /usr/local/lib

b. Ensure the emulator libraries are picked up by the Shader Server: 
sudo /sbin/ldconfig

c. Enter a name for the software renderer in the Connection Name field. See 
Figure 2-9.

Figure 2-9 The Add Renderer dialog with the emulator renderer

d. Enter the local host address, which is always 127.0.0.1, in the Connection Name 
field.

e. Enter a local port address in the Connection Port field. This address will be passed 
to the Shader Server when it starts.

f. Click OK
g. Restart eclipse if it is already open. 
To use a hardware renderer in an attached system:
a. Enter a name for the hardware renderer in the Connection Name field
b. Use /sbin/ifconfig on the target to get its internet address. Enter this value in the 

Connection Address field.
c. Enter the port address which you used to start the Shader Server on the target in the 

Connection Port field. See Appendix A Shader Server.
d. Click OK

4. The renderer is added to the list. See Figure 2-10 on page 2-12:
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-11
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Installing the software 
Figure 2-10 Eclipse Preferences dialog box with Linux renderer added

5. Click OK to save the preferences that have been set and to close the Preferences dialog 
box.

6. The Shader Development Studio software is now configured. 
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-12
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Installing the software 
2.4 Uninstalling the Shader Development Studio Plug-in
To uninstall the Shader Development Studio plug-in for future updates:

1. Select Help → Install new software → already installed

2. Select Mali GPU Shader Development Studio and click Uninstall ....

3. The uninstall details list is displayed. Select Mali GPU Shader Development Studio and 
then click Finish to remove the plug-in. 

4. Restart Eclipse and to confirm that the removal was successful, select Window → Open 
Perspective → Other .... See Figure 2-11.

Figure 2-11 Plug-in removed

Note
 • With some installations you can see the icon <Mali Shader Development Studio> left in 

the open perspective window. If you click on this icon nothing happens, because the 
plug-in has already been correctly un-installed.

• You can use the Add or Remove option in the Windows Control Panel to remove the local 
update site.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 2-13
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Chapter 3 
The Shader Development Studio

This chapter describes how to get started using the Shader Developer Studio. It contains the 
following sections:
• Opening the Shader Development Studio perspective on page 3-2
• Creating a new Shader effect on page 3-3
• Importing existing Shader effects and configurations on page 3-14
• Shader syntax checking on page 3-17
• Shader animation on page 3-19.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 3-1
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The Shader Development Studio 
3.1 Opening the Shader Development Studio perspective
The Shader Development Studio software comes with a pre-built Eclipse perspective that can 
be used to start developing shaders for the Mali GPUs.

To open the Shader Development Studio perspective from Eclipse:

1. Start Eclipse.

2. Select Window → Open Perspective → Other ....
The Open Perspective dialog box is displayed. 

3. Click Shader Development Studio in the Open Perspective dialog box.

4. Click OK.
The Shader Development Studio perspective is loaded. See Figure 3-1:

Figure 3-1 Shader Development Studio perspective

The views of the perspective can be moved and resized, docked and undocked, or 
dismissed altogether if they are not required. 
To open individual views, select Window → Show View and select the view you require.
For more information about the views provided by the Shader Development Studio, see 
Views on page 4-8.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 3-2
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The Shader Development Studio 
3.2 Creating a new Shader effect
This section describes how to use the Shader Development Studio to create a new shader effect.

A shader effect is a collection of vertex and fragment shaders that make up a single shader 
program that can be rendered on a target. A project can have multiple shader effects, each of 
these can share shader source files. The shader effects are contained in and managed by a Shader 
Configuration File. A project can only have one shader configuration file, that must exist at the 
root level of the project.

3.2.1 Creating a new Vertex and Fragment Shader

To create a new shader effect, you must create the source files that comprise the effect and then 
add the source files to a project. 

The Shader Development Studio works with any kind of project that can be created in Eclipse 
including a Java Project and a C Project. Eclipse provides wizards for creating these projects, 
and the Shader Development Studio provides wizards to guide you through the creation of 
shader-specific resources. For more information about the wizards provided by the Shader 
Development Studio, see Wizards on page 4-5.

For example, to create a new Java project with a Vertex Shader and Fragment Shader:

1. Select File → New → Project ...
The New Project dialog box is displayed. See Figure 3-2:

Figure 3-2 New Project dialog box

2. Click Java Project.

3. Click Next.
The New Java Project - Create a Java project dialog box is displayed.

4. Enter a name for the project. For example, SimpleTest.

5. Click Next.
The New Java Project - Java Settings dialog box is displayed.

6. Click Finish.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 3-3
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The Shader Development Studio 
The Open Associated Perspective dialog box is displayed asking if you want to open the 
Java perspective.

7. Click No.
The new project is created in the Package Explorer pane of the Shader Development 
Studio. See Figure 3-3:

Figure 3-3 New project in Shader Development Studio

8. Click the + icon next to the SimpleTest project in the Package Explorer pane to expand 
the contents.

9. Right-click on the src directory and select New → Vertex Shader.
The Vertex Shader dialog box is displayed. See Figure 3-4 on page 3-5:
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The Shader Development Studio 
Figure 3-4 New Vertex Shader dialog box

10. Enter a name for the shader, for example simple.vert, in the Filename edit field

11. To add the shader to an effect, check the Add file to shader effect box.

12. Click Finish.
The vertex shader is created in the src directory.

13. Right-click on the src directory again and select New → Fragment Shader. The 
Fragment Shader dialog box is displayed.

14. Enter a name for the shader, for example simple.frag, in the Filename edit field.

15. Click Finish.
The fragment shader is created in the src directory.

16. Two files are created in the src directory that contain the source code for a trivial shader 
effect. See Figure 3-5 on page 3-6:
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The Shader Development Studio 
Figure 3-5 Files generated by Eclipse Wizards

3.2.2 Creating a new Shader Configuration File

This section describes how to create a shader configuration file. The configuration file is 
required to link the fragment shader and vertex shader source files together to produce an overall 
effect. The shader configuration file configures the type of effect that is produced. 

To create a new shader configuration file:

1. Right-click on the SimpleTest project in the Package Explorer pane and select New → 
Shader Configuration.
The Shader Configuration dialog box is displayed.

2. Click SimpleTest.

3. Click Finish.

4. The Shader Configuration file (named shaders.shaderconfig) is created in the SimpleTest 
project and the Shader Configuration Editor pane is displayed. See Figure 3-6 on 
page 3-7:
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The Shader Development Studio 
Figure 3-6 Shader Configuration Editor

For more information about the shader configuration editor, see Shader Configuration 
editor on page 4-6.
The shader configuration editor enables you to manage shader effects for a project. A 
default effect, called New Effect, is created when the shader configuration is created. The 
default effect is used for this example.
The shader configuration editor separates vertex and fragment shaders into two lists. You 
can add any source file in the project to these lists. This enables utility shader sources, that 
are neither specifically vertex or fragment shader sources, to be reused.

5. Click Add Shader in either the Vertex Shaders section or the Fragment Shader section.
The Resource Selection dialog box is displayed. 

6. Click the + icon next to SimpleTest and then click the src folder. See Figure Figure 3-7:

Figure 3-7 Resources dialog box

7. Click the check box next to simple.vert.
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The Shader Development Studio 
8. Click OK.
The shader source is added to the effect.

9. To add a shader to the shader sectioneither:
• Use the buttons on the dialog:

1. Click Add Shader in the Fragment Shaders section.
2. Click the + icon next to SimpleTest and then click the src folder.
3. Click simple.frag in the Resource Selection dialog box.
4. Click OK.

• Drag a shader from the Package Explorer window or the Project Explorer window 
into the Vertex Shaders or Fragment Shaders list.

10. The Shader Configuration Editor contains the shaders. See Figure 3-8:

Figure 3-8 Edited Shader Configuration Editor

11. Select File → Save to save the configuration.
You have created your first shader effect called New Effect.

Note
 Eclipse displays warning messages in the Problems pane when the shader effect is 

created. These warnings are a result of uninitiated uniform and attribute variables in the 
shader programs. These can be ignored and eventually disappear after completing the 
Rendering the shader effect on page 3-9 section.
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The Shader Development Studio 
3.2.3 Rendering the shader effect

The shader effect created in the previous section can be rendered in the Shader Preview view. 
This view shows the result of rendering a shader on the selected target.

To render the shader effect:

1. If it is not already open, open the Shader Preview view. To open this view, select 
Window → Show View and select the Shader Preview view.

2. In the Shader Preview view, click the Select Renderer icon  and select an appropriate 
renderer from the menu displayed. 
A tick appears next to the renderer that is currently in use. See Figure 3-9:

Figure 3-9 Selected renderer in Shader Preview view

3. In the Shader Control view, click the Select Shader to Render icon  and select 
SimpleTest → New Effect. See Figure 3-10: 

Figure 3-10 Selected shader in Shader Control view

A Progress bar is displayed in the Shader Preview view to indicate that the selected shader 
is being rendered by the target. The rendered image is then displayed in the Shader 
Preview view.

Note
 Although the image is rendered, no actual image is displayed in the view. This is because 

the geometry vertices and the camera matrix have not yet been set for the selected shader. 
To fix this, adjust the values of the uniforms and attributes in the shader. Two warning 
messages are issued about this in the Problems view, if you have it open. To assign values 
to attributes and uniforms use the Shader Attributes and Shader Uniforms views.
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4. Click the Shader Attributes view alongside the Shader Control view. 
The Shader Attributes view is displayed. See Figure 3-11:

Figure 3-11 Shader Attributes view

5. In the Value column, click the cell corresponding to the value of the coord attribute.
A button is displayed in the cell.

6. Click the button.
The Matrix and Vector editor is displayed. See Figure 3-12:

Figure 3-12 Matrix and Vector editor

7. Select VERTICES from the drop-down menu.

8. Click OK.
This action assigns vertex values for the currently selected geometry to the coord attribute.

Note
 The warning message about this is automatically removed from the Problems view.

9. Click the Shader Uniforms tab alongside the Shader Attributes tab. 
The Shader Uniforms tab is displayed. See Figure 3-13:

Figure 3-13 Shader Uniforms view

10. In the Initial Value column, click the cell corresponding to the value of the camera 
uniform required for inspection and modification.
A button is displayed in the cell.

11. Click the button.
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The Matrix and Vector editor is displayed. See Figure 3-14:

Figure 3-14 Matrix and Vector editor

12. Select CAMERA_MATRIX from the drop-down menu.

13. Click OK.
This action assigns values to the camera uniform.

Note
 The warning message about this is automatically removed from the Problems view.

14. Click the Render Single Frame icon  in the Shader Preview view.
A graduated-color square is displayed in the preview. See Figure 3-15:

Figure 3-15 Render view of SimpleTest shader

3.2.4 Editing the effect

This section describes how to edit the shader effect that was produced in the previous section.

To edit the shader effect:

1. In the Shader Preview view, click the Default Rendering Mode icon  and select 
Automatically Render One Frame from the menu displayed. 
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This setting causes the Shader Preview view to update the preview when the components 
of the shader effect are changed. For example:
• shader source files
• shader attributes
• shader uniforms.

2. In the Package Explorer view, double-click simple.frag in the src directory.
The simple.frag shader source file is opened in Eclipse.

Figure 3-16 simple.frag edit view

3. Change the line:
gl_FragColor = vec4((v.x+1.0)/2.0, (v.y+1.0)/2.0, (v.z+1.0)/2.0, 1.0);

to:
gl_FragColor = vec4(1.0, 1.0, 1.0, 1.0);

4. Select File → Save to save the file,
The Shader Preview view is updated to show a solid white square instead of the 
graduated-color square.

5. Change the edited line back to the original version. You can use Ctrl-Z to undo the 
changes made.
The Shader Preview view is updated to show the original graduated color square.

3.2.5 Rendering with different geometries

Currently, the shader effect is being rendered onto a simple geometric plane. The Shader 
Development Studio comes with several pre-built models that you can use to render to instead 
of a simple plane. The models include basic shapes such as a sphere and cube, to more complex 
shapes like a rock and a chess piece.
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To render using a different geometry, such as a torus:

1. Click on the Shader Control view.
The Shader Control view is displayed. See Figure 3-17:

Figure 3-17 Shader Control view

Note
 If necessary, resize the Shader Control view to display the Scene Control group box.

2. Select TORUS from the Geometry drop-down list box in the Scene Control box.
The Shader Preview window is updated to show a torus with the shader effect rendered 
on its surface. See Figure 3-18:

Figure 3-18 Torus geometry

The torus is a three-dimensional geometry, but it looks two-dimensional, see Figure 3-18. 
This is because the simple shader effect does not perform any lighting calculations, so no 
shadows are present to give depth cues.
In the next section, an advanced shader example is used that implements lighting 
calculations and shows the torus is a three-dimensional geometry.
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3.3 Importing existing Shader effects and configurations
To create a new Generic Project in Eclipse and import the example shader content from the Mali 
Shader Library into this project:

1. Install the Offline Shader Compiler and Shader Library as described in Mali Developer 
Tools on page 2-2.

2. Select File → New → Project ...
The New Project dialog box is displayed.

3. Select General → Project.

4. Click Next.
The New Project dialog box is displayed.

5. Enter a name for the project. For example, ExampleContent.

Note
 The project is set to Create a new project from workspace. To avoid a known issue 

documented in the Mali GPU Shader Development Studio Errata, ARM recommends you 
choose the option Create project from existing source while creating new eclipse java 
project for the shader sources. Only the Create project from existing source is 
described. 

6. Copy the ShaderExamples folder to your work area, it is located at:
C:\Program Files\ARM\Mali Developer Tools\Mali GPU Shader Library vm.n

In this example the location for the work area is:
C:\Mali Developer Tools Work Area\

Note
 This is done to prevent any data corruption occurring in the original folder.

7. Right-click the newly created project and select Import.

8. The shader configuration files in the Mali GPU Shader Library not compatible with the 
Shader Development Studio version 1.3. Use the new configuration files that are in the 
Shader Development Studio Examples folder:
Copy the Examples\ShaderExamples\shader.shaderconfig file from the Shader 
Development Studio installation directory to the ShaderExamples folder in your work area.

Note
 Copying the new configuration files overwrites the existing files.

9. Select General → File System.

10. Click Next.

11. Select Browse ... and navigate to the ShaderExamples folder in your work area.

12. Click OK.

13. Click Select All.

14. Click Finish.
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15. The new project is created in the Package Explorer pane of the Shader Development 
Studio.
The selected files are imported into the project. See Figure 3-19:

Figure 3-19 Example content in project

Note
 The steps to create a new Eclipse project for OrangeBookExamples, also present in Mali 

Shader, are similar.

The example content available in the Shader Library contains some more advanced 
shaders that implement the complex graphics effects that were missing from the example 
shader effect used in previous sections. 
A pre-built shader configuration file is supplied with the example content that contains 
pre-made shader effects, so you do not have to create a shader configuration manually. 
Instead, the shader effects can be rendered immediately.

16. In the Shader Control view, click the Select Shader to Render icon  and select 
ExampleContent → Demo 04 - Lighting.
The torus is re-rendered in the Shader Preview view, but this time lighting calculations 
are applied. The torus is now three-dimensional. See Figure 3-20 on page 3-16:
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Figure 3-20 Demo - 04 - Lighting effect

Try changing the preview model in the Shader Control view to see the effects that are 
produced by the other geometry models provided in the example content.
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3.4 Shader syntax checking
If you do not have the Offline Compiler available, you can skip this section. For more 
information about the Offline Compiler, see Mali GPU Developer Tools Overview.

Each time a shader source file is saved, the Shader Development Studio compiles the shader in 
the background using the offline compiler. If any errors are found, error messages are displayed 
in:

• Problems view.

• Alongside the offending line of the shader source file, if it is open in the shader source 
editor.

To see how errors are displayed by Eclipse:

1. Open the file simple.frag in the SimpleTest project.

2. Remove the semi-colon at the end of the vec4 expression.

3. Save the file.
A red error marker is displayed on the line beneath the vec4 expression line. See 
Figure 3-21:

Figure 3-21 Error indicator in shader source editor

Similar to a C compiler, the offline compiler reports a missing semicolon as an error on 
the next line.
The removal of the semi-colon generates four separate error messages in the Problems 
view. See Figure 3-22:

Figure 3-22 Errors in Problems view
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4. Replace the semi-colon and save the file.
The source file is compiled in the background by the offline compiler, because there are 
no errors in the source code, the error marker is removed from the source editor and the 
error messages are removed from the Problems view.
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3.5 Shader animation
The Shader Development Studio also supports shader animation. This can be used to see how a 
shader effect changes over time. This section describes how to set up a shader for animation and 
how to animate the shader.

3.5.1 Setting up a shader to use animation

A shader is animated using a key framing method. Values are set for the initial frame and final 
frame, the Shader Development Studio then interpolates the values between these two frames to 
create the animation effect.

The Environment Mapping shader demo provided in the content directory is set up to use 
animation. To view how animation has been setup for this shader:

1. Open the project that you created containing the Example content provided with the 
Shader Development Studio software. See Importing existing Shader effects and 
configurations on page 3-14. 

2. In the Shader Control view, select ExampleContent → Demo 07 - Environment 
Mapping.
The Shader Preview is updated to show a custom geometry called ARM, with environment 
mapping applied. See Figure 3-23:

Figure 3-23 ARM geometry

3. The Shader Control view and the Shader Uniforms view set up the key framing 
parameters for the shader animation.
In the Camera control group box in the Shader Control view, values are set for:
• camera position for the first frame, this is also the camera position used to render 

single-frame shaders
• camera position of the last frame and the number of frames to render. See 

Figure 3-24 on page 3-20:
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Figure 3-24 Shader Control view

In the Shader Uniforms view, initial values and final values are set for each uniform 
listed. These are the values that are interpolated to make the animation. See Figure 3-25:

Figure 3-25 Shader Uniforms view

3.5.2 Animating the shader

This section describes how to animate the Environment Mapping shader demo.

The Environment Mapping shader demo effect already has key frame values set, so the 
animation can be generated immediately. To render all frames:

1. Click the Render All Frames icon  in the Shader Preview view.
A Progress bar is displayed in the Shader Preview view to indicate that the selected 
shader is being rendered by the target. The first frame of the animation is displayed in the 
Shader Preview view.

2. Use the transport controls beneath the preview to control the animation. 
Click Play Forward to start the animation. The shader preview shows the number of 
frames requested, interpolated between the initial frame and final frame. See Figure 3-26 
on page 3-21:
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Figure 3-26 Environment Mapping animation

For more information about animating shaders, see Shader Control on page 4-9 and Shader 
Uniforms on page 4-11.
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Chapter 4 
Configuring the Shader Development Studio

This chapter describes all the options that are available for configuring the behavior of the 
Shader Development Studio. The sections in this chapter are:
• Configuration on page 4-2
• Wizards on page 4-5
• Editors on page 4-6
• Views on page 4-8.
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4.1 Configuration
This section describes the general configuration options for the Shader Development Studio. 

To view all the options available, select Preferences from the Window menu. The Preferences 
dialog box is displayed.

The sections describe the options displayed in this dialog box.

4.1.1 Shader Development Studio

To view the options for the Shader Development Studio, click Shader Development Studio in 
the Preferences dialog box.

This pane sets general options for the Shader Development Studio. See Figure 4-1:

Figure 4-1 Shader Development Preferences pane

Automatically Render

The Automatically Render group box sets the updating preference for the preview window. 
The options are:

Never Do not automatically render any frames at any point. You can perform manual 
rendering by clicking on the:

• Render Single Frame icon  , or

• Render All Frames icon  in the Shader Control view.

Single Frame Only 
Only render the first frame of a shader animation, even if more frames are 
requested in the Shader Control view.
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All Frames Always render all requested frames.

4.1.2 Compiler

This preference pane sets options for the offline shader compiler. The offline shader compiler is 
used to check shader source files for errors and to report performance statistics of shaders. See 
Figure 4-2:

Figure 4-2 Compiler preferences pane

Use Offline Shader Compiler

If this box is checked, the offline shader compiler is used to check shaders for errors. 
Unchecking this box disables this behavior.

Offline Shader Compiler Executable

The location of the offline shader compiler executable. The offline shader compiler is provided 
as part of the Mali Developer Tools.

Hardware Revision

The hardware revision of the Mali GPU to compile shader effects for. If you are not writing 
shader effects for the latest version of the Mali hardware, set this to the hardware revision you 
are developing for. 

This setting causes the compiler to report revision-specific errors. The Use latest revision 
option defaults to use the latest version of the Mali hardware. For more information, see the 
documentation for malisc.exe in the Mali Offline Shader Compiler User Guide.

4.1.3 Renderers

The Renderers pane of the Preferences dialog box controls connections to available renderers 
that are detected on the local network. See Figure 4-3 on page 4-4:
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Figure 4-3 Renderers Preferences pane

For more information about using the Renderers pane, see Select a renderer on page 2-9.

Renderer Information

This list is a static collection of renderers that have been added during the use of the Shader 
Development Studio.

Each entry has two fields that display information about the renderer:

Name The name of the renderer.

Address The IP address and port number of the renderer.

Add Renderer ...

Click Add Renderer to open a dialog box that enables you to manually specify a renderer. The 
following data is required for each renderer added:

Name Name for the connection, as it appears in the Renderers list.

Address The IP address of the renderer.

Port The TCP port used to communicate with the renderer. The default connection port 
is port 3472.

Remove Renderer

Remove the renderer currently selected in the list.

Edit Renderer ...

Edit the details of the currently selected renderer.
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4.2 Wizards
This section describes the wizards that are provided by the Shader Development Studio.

4.2.1 New Vertex Shader

The New Vertex Shader wizard (accessed from File → New → Vertex Shader) creates a new, 
trivial vertex shader in the selected parent folder. The file name can be any file name accepted 
by the host operating system. The Shader automaticallyadds a .vert extension to the file name.

For more information about using the New Vertex Shader wizard, see Creating a new Shader 
effect on page 3-3.

4.2.2 New Fragment Shader

The New Fragment Shader wizard (accessed from File → New → Fragment Shader) creates 
a new, trivial fragment shader in the selected parent folder. The file name can be any file name 
accepted by the host operating system. The Shader automaticallyadds a .frag extension to the 
file name.

For more information about using the New Fragment Shader wizard, see Creating a new Shader 
effect on page 3-3.

4.2.3 New ESSL File

The new ESSL File wizard (accessed from File → New → ESSL File) creates a new generic 
shader file that can be included alongside vertex and fragment shaders in a shader effect. ESSL 
files are useful for creating #define values for use in vertex and fragment shaders.

When using additional ESSL files, you must place them before the vertex and fragment shaders 
in the shader effect configuration, or the values created in the ESSL file might not be visible in 
the other files. The compiler concatenates each of these files together, including the available 
vertex and fragment shaders, before compiling the source.

4.2.4 New Shader Configuration

The New Shader Configuration wizard creates a new shader configuration file in the selected 
project. No other shader configuration file can exist in the project. The wizard creates a shader 
configuration with a default shader effect, named New Effect, that has no shader sources defined 
in it.

For more information about using the New Shader Configuration wizard, see Creating a new 
Shader Configuration File on page 3-6.
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4.3 Editors
This section describes the editors that are provided by the Shader Development Studio.

4.3.1 Shader editor

The Shader editor provides functionality for editing vertex and fragment shader files. This 
includes syntax highlighting, error reporting and shortcuts for rendering shader effects.

4.3.2 Shader Configuration editor

The Shader Configuration editor provides a method for editing a shader configuration file.

For more information about using the Shader Configuration Editor, see Creating a new Shader 
Configuration File on page 3-6.

Current Effect

The current shader effect is shown in the Current Shader Effect drop-down list. To select a 
different effect, select it from the list. The other fields in the editor reflect the contents of the 
currently selected effect.

Add New Effect 
Creates a new, empty shader effect. A dialog box prompts for a name for the 
shader effect. Clicking OK creates the effect and causes the editor to switch to 
this effect

Rename Effect 
Renames the currently selected shader effect. A dialog box prompts for a new 
name. Clicking OK renames the effect.

Remove Effect 
Removes the shader effect from the configuration.

Vertex Shaders section

The vertex shaders section lists all the shader source files that make up the vertex part of the 
shader effect. It is valid to put a non-specific shader, one that is neither a vertex nor a fragment 
shader, in this list. But, be aware that the shader is compiled and checked for errors as a vertex 
shader by the offline compiler. Ordering of source files might be important to the functionality 
of the shader effect, so buttons are provided to re-order the list.

New Shader Create a shader with the default shader code and adds it to the list. 

Add Shader Add an existing shader source file to the list. The source file must belong to the 
current project.

Remove Shader 
Remove the selected shader source file from the list.

Move Up Move the selected shader source file up one position. The shader sources are 
passed to the compiler in the order they appear in the list.

Move Down Move the selected shader source file down one position. The shader sources are 
passed to the compiler in the order they appear in the list.
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Fragment Shaders section

The fragment shaders section lists all the shader source files that make up the fragment part of 
the shader effect. 

Note
 It is valid to put a non-specific shader, one that is neither a vertex nor fragment shader, in this 
list. But, be aware that the shader is compiled and checked for errors as a fragment shader by 
the offline compiler. Ordering of source files might be important to the functionality of the 
shader effect, so buttons are provided to re-order the list.

New Shader Create a shader with the default shader code and adds it to the list. 

Add Shader Add an existing shader source file to the list. The source file must belong to the 
current project.

Remove Shader 
Remove the selected shader source file from the list.

Move Up Move the selected shader source file up one position. The shader sources are 
passed to the compiler in the order they appear in the list.

Move Down Move the selected shader source file down one position. The shader sources are 
passed to the compiler in the order they appear in the list.

4.3.3 Matrix and Vector Editor

You can use the Matrix and Vector editor to edit shader attribute and uniform values in the 
Shader Attributes view and Shader Uniforms view. The editor presents a table that can be used 
to edit the values of vector and matrix OpenGL ES 2.0 types. The drop-down list at the top of 
the editor enables loading of pre-defined values. The exact functionality available in the editor 
is dependent on the context it is used in.

Import Import values from a Comma Separated Value file.

Export Export the current values to a Comma Separated Value file.

For more information about the Matrix and Vector Editor, see Rendering the shader effect on 
page 3-9.

Note
 You can copy and paste attributes and uniforms values. 

4.3.4 Sampler Editor

The Sampler editor is used to edit settings for OpenGL ES 2.0 sampler types (sampler2D, 
samplerCube).

Texture Select the texture to be used for the sampler.

Use Built-in If checked, use one of the built-in textures for this sampler. Select a texture from 
the drop down list. If unchecked, use the Browse… button to select a texture from 
the project.

The Sampler editor also specifies how OpenGLES filters and wraps the texture.
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4.4 Views
This section describes the different Views that are provided by the Shader Development Studio.

4.4.1 Shader Preview

The Shader Preview view provides visual feedback about the currently selected shader effect. 
For information about selecting a shader effect, see Shader Control on page 4-9. The current 
shader effect is displayed at the top of the view. The view is mainly occupied by the Shader 
preview, that shows a preview of how the currently selected shader effect looks when rendered 
on the current renderer.

When a preview is being displayed, you can right-click on the preview to save the preview 
frames as a series of image files.

For more information on using the Shader Preview view, see Rendering the shader effect on 
page 3-9.

Animation transport

The animation transport contains a set of buttons to control the animation of shaders that have 
more than one frame. See Figure 4-4:

Figure 4-4 Animation transport controls

Table 4-1 describes the use of the slider and buttons: 

Toolbar

The toolbar menu of the Shader Preview view contains a set of buttons that control the current 
renderer. See Figure 4-5:

Figure 4-5 Toolbar buttons

Table 4-1 Animation transport buttons

Button Description

Slider The slider at the top shows the position in the current 
animation, and can also be dragged to move through the 
animation.

Rewind to Start Set the current frame to the initial frame.

Play in Reverse Play from the current frame to the initial frame.

Stop Stop the animation.

Play Forward Play from the current frame to the final frame.

Fast Forward to End Set the current frame to the final frame.
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Table 4-2 describes the toolbar buttons: 

Context menu

The Context menu is displayed by right-clicking over the animation. The buttons on the Context 
menu are described in Table 4-3: 

4.4.2 Shader Control

The Shader Control view controls the Shader Preview view. It is used for:
• selecting the shader effect to be rendered
• selecting the geometry to render the effect onto
• selecting the number of frames to be rendered
• controlling the camera position for the first and last frame.
• controlling the number of frames to be rendered.

The top of the Shader Control view displays the currently selected shader effect.

Table 4-2 Toolbar buttons

Button Name Description

 
Compare Frames Compare the currently displayed frame with last frame rendered.

 
Save Current Frame Save the currently displayed frame to disk.

Save All Frames Save all the frames of the current shader effect to disk.

 
Render Single Frame Render a single frame of the current shader effect.

 
Render All Frames Render all the frames, as specified by Number of Frames in the Shader 

Control view, of the current shader effect.

 
Set Preview Size Change the size if the preview area.

 
Select Default Rendering Mode Change the default rendering mode. This preference is synchronised with 

the Automatically Render setting on the Shader Development Studio 
preference pane, see Automatically Render on page 4-2.

 
Select Renderer Select a renderer to render the current shader effect. This list is populated 

from the Renderers preference pane, see Renderers on page 4-3.
At the end of the list is Manage Renderers. This provides a shortcut to the 
Renderers preferences page. See Renderers on page 4-3.

Table 4-3 Context buttons

Menu item Description

Save Current Frame Save the currently displayed frame to disk.

Save All Frames Save all the frames of the current animation to disk.

Set Background Color Set the color to render the background in the preview. This setting is 
synonymous with the glClearColor OpenGL ES 2.0 function.
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For more information on using the Shader Control view, see Rendering with different geometries 
on page 3-12.

Performance info ...

Displays a dialog box that provides statistics on the performance of the current shader effect. 
See Figure 4-6:

Figure 4-6 Performance Info dialog box

Camera control

The Camera control group box controls the camera positions and settings for rendering shader 
effects. The settings are described in Table 4-4:

Scene control

The Scene Control group box controls how a scene is rendered in the Shader Preview view. The 
settings are described in Table 4-5:

Table 4-4 Camera control buttons

Setting Description

First Frame Sets the X, Y, Z and zoom values for the camera in the first frame.

Last Frame Sets the X, Y, Z and zoom values for the camera in the last frame.

Orthographic Projection If this box is checked, the geometry is rendered in orthographic projection 
mode in the Shader Preview view.

Number of Frames Sets the number of frames to render for shader animation. The values of the 
uniforms, attributes, and camera values for the shader are interpolated over 
this number of frames.

Table 4-5 Scene control buttons

Button Description

Enable Blending Enables the blending capability provided by OpenGL ES.

Configure Blending Options Display a dialog to configure how OpenGL ES performs blending.

Geometry Selects the geometry to render the shader effect on.
DUI0504C Copyright © 2009-2011 ARM. All rights reserved. 4-10
ID120911 Non-Confidential - Beta



Configuring the Shader Development Studio 
Toolbar

The toolbar menu of the Shader Control view contains a set of items that control the current 
shader effect.

4.4.3 Shader Attributes

The Shader Attributes view presents a list of all attributes in the current shader effect. This list 
is generated from the data in the shader effect.

For more information about using the Shader Attributes view, see Rendering the shader effect 
on page 3-9.

Table 4-7 describes the shader attributes that are displayed in the Shader Attributes view:

4.4.4 Shader Uniforms

The Shader Uniforms view presents a list of all uniforms in the current shader effect. This list 
is generated from the data in the shader effect.

For more information about using the Shader Uniforms view, see Rendering the shader effect 
on page 3-9.

Table 4-6 Toolbar control buttons

Button Name Description

Copy values Displays a dialog that enables you to copy all shader sources, control 
settings, attribute settings, and uniform settings.

Open Source for this Shader Open any shader source files associate with the currently selected 
shader effect.

Reload Shader Configuration Reload the shader effect’s attributes, uniforms, camera and scene 
control settings from the data stored in the shader configuration.

Save Settings to Shader Configuration Write the current shader effect’s uniform, attribute, camera control 
and scene control values back into the shader configuration.

Select Shader to Render Click this button to open a menu system that enables navigation to 
all known shader effects in all open projects.
Click on any effect displayed to cause the Shader Preview view to be 
updated with the selected shader effect. The automatic rendering 
preference is used to determine if the selected shader is rendered. 
See Automatically Render on page 4-2.

Table 4-7 Shader Attributes

Attribute Description

Loc The location of the attribute in the shader, as assigned by the renderer.

Name The name of the attribute as it appears in the shader source file.

Type OpenGL ES Type of the attribute.

Value Value of the attribute. Click on this cell to present an editor appropriate to the type of the attribute. For 
example, vectors and matrices present a table editor, though for single-value types such as float, the current 
cell is edited.
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Table 4-8 describes the shader uniforms that are displayed in the Shader Uniforms view:

Table 4-8 Toolbar control buttons

Button Description

Loc The location of the uniform in the shader, as assigned by the renderer.

Name The name of the uniform as it appears in the shader source file.

Type The OpenGL ES Type of the uniform.

Initial Value The value of the uniform for the first frame.
For animation, this is the initial value the uniform values are interpolated from. 
For a single frame shader effect, this sets the value of the uniform for that frame. 
Clicking on this cell presents an editor appropriate to the type of the attribute.

Final Value The value of the uniform for the last frame. 
For animation, this is the final value the uniform values are interpolated to. 
For a single frame shader effect, this has no effect.
Clicking on this cell presents an editor appropriate to the type of the attribute.
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Appendix A 
Shader Server

This appendix describes how to use a remote renderer for the Shader Development Studio. It 
consists of the following section:

• About the Shader Server on page A-2.
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A.1 About the Shader Server
Shader Server is a remote renderer for the Shader Development Studio. It accepts Mali Remote 
Interface and OpenGL ES 2.0 calls over the network, executes those calls on Mali-200 or 
Mali-400 hardware, and returns the results to the client.

It consists of two parts:
• A library implementing the communication protocol and function dispatch,called libmri.
• A remote implementation of the function calls, that interfaces withOpenGL ES 2.0 and 

the operating system.

The source code provided is designed to be built for an ARM based Linux operating system, 
with Mali-200 or Mali-400 OpenGL ES 2.0 drivers.

This section describes:
• Requirements
• Contents
• Building on page A-3
• Usage on page A-4
• Security on page A-4
• Porting on page A-5.

A.1.1 Requirements

The Shader Server source code is provided as part of the Shader Development Studio. 

Note
 If you require the source code for the Shader Server, unzip the downloaded file. 

To build the Shader Server you require: 

• a recent GNU compiler toolchain targeting the ARM architecture, including:
— C++ compiler,
— linker
— archiver
— Make.

• an OpenGL ES 2.0 driver to link against.

The Shader Server has been successfully built and tested on a computer with:
• Fedora 8 (32-bit) with Linux kernel 2.6.25.11-60.fc8
• ARM GCC cross compilation toolchain 4.2.0 20070413
• Make 3.81.

A.1.2 Contents

The source code consists of: 

• readme.txt 

• Makefile

• libmri/

— glesfunctiontable.h

— gleslocalfunctions.c
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Shader Server 
— gleslocalfunctions.h

— Makefile

— mrp.h

— mrpclient.cpp

— mrpclient.h

— mrperror.cpp

— mrperror.h

— mrpmessagedecoder.cpp

— mrpmessagedecoder.h

— mrpmessageelement.cpp

— mrpmessageelement.h

— mrpmessageencoder.cpp

— mrpmessageencoder.h

— mrpnetio.cpp

— mrpnetio.h

— mrpserver.cpp

— mrpserver.h

— mrpstring.cpp

— mrpstring.h

• Shader Server/

— dogles_remote_implementation/
bufferhandling.cpp

drawingcontrol.cpp

logging.cpp

peermanagement.cpp

performance_counters.cpp

renderingcontrol.cpp

state.cpp

state.h

— Mali200/3rdparty/include/khronos/EGL/eglplatform.h

— Mali200/3rdparty/include/khronos/EGL/fbdev_window.h

— Mali200/3rdparty/include/khronos/KHR/khrplatform.h

— Makefile

— ShaderServer.cpp

— stafx.cpp

— stafx.h

A.1.3 Building

To build the shader for the Mali-200 reference platform:

1. Go to the installed location for the Shader Development Studio.

2. Change to the Shader Server directory.
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Shader Server 
3. Download the following Khronos OpenGL ES 2.0 header files from the Mali Developer 
Center web site at: http://www.malideveloper.com
• GLES2/gl2.h

• GLES2/gl2ext.h

• GLES2/gl2platform.h

4. Copy gl2.h, gl2ext.h, and gl2platform.h to: 
installation_directory/ShaderServer/MALI200/3rdparty/include/khronos/GLES2

5. Download the following Khronos EGL header files from the Mali Developer Center 
website at: http://www.malideveloper.com
• egl.h

• eglext.h

6. Copy egl.h and eglext.h to:
installation_directory/ShaderServer/MALI200/3rdparty/include/khronos/EGL

7. In the files libmri/Makefile and ShaderServer/Makefile, modify the MALI_LIB_DIR 
variables to point to the Mali-200 or Mali 400 OpenGL ES 2.0 driver libraries.

8. Change to the root level, that is the directory that contains libmri and ShaderServer, and 
enter make.

9. The source code builds and produces an executable called shaderserver in the 
ShaderServer directory. You can copy this to your ARM development platform.

A.1.4 Usage

Start the Shader Server with argument --help for usage information.

The Shader Server requires a port and a server name as arguments:

shaderserver -p port -n name [-l] [-v]

where:

port is the network port number on the platform's network interface used to listen for 
incoming connections. Shader Development Studio searches for servers between 
ports 3472 and 3476, by default.

name is an identifier string that is displayed by the Shader Development Studio when it 
discovers the server.

-l If present, this switch causes the server to listen for connections from only the 
localhost (127.0.0.1).

-v If present, this switch turns on verbose output for debugging.

A.1.5 Security

Running Shader Server permits any remote user to connect to your platform and execute 
OpenGL ES 2.0 code with the privileges of the user that the server is run by.

It must be considered an INSECURE service, and must only be made accessible from a trusted 
network or through VPN or Secure Shell (SSH) tunneling.
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Shader Server 
A.1.6 Porting

The Shader Server depends on the following components:

• C library functions for example malloc, free, and string operations. These are called 
through #defines, found at the beginning of mrp.h.

• BSD style network socket functions for example, bind, listen, accept, send, and recv. 
Calls to these functions are found in the mrpclient.cpp, mrpserver.cpp and mrpnetio.cpp.

• OpenGL ES 2.0 functions. These are called through a generic function call mechanism in 
mrpserver.cpp. The list of available functions is defined in the array of structures in 
glesfunctiontable.h.

Porting the code to an alternative operating system or platform requires these three components 
to be provided or emulated.
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